Qbasicnews.com
May 26, 2020, 06:57:17 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Back to Qbasicnews.com | QB Online Help | FAQ | Chat | All Basic Code | QB Knowledge Base
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: darken  (Read 4773 times)
andy
Senior Member
**
Posts: 175



WWW
« Reply #15 on: October 21, 2003, 04:40:52 AM »

Thanks, I can confirm it, I have QB v1.1. I have v7.1 on my laptop, but that is off for repair. I should get it back soon.
By the way what differences are there between v1.1 and v7.1 in the coding, not the interface.
Logged

eminiscing about trapezoids in conjunction with stratospherical parabolas:

No questions asked.

www.stickskate.com
toonski84
__/--\__
*****
Posts: 2567



« Reply #16 on: October 21, 2003, 07:15:27 AM »

Well, the biggest, most important difference between 1.1 and any other version is that it can't compile .exes.  You see, 1.1 is really cripped shareware of an updated version of 4.5 that they distributed with dos (and consequently windows).  It can also do things like run .qlb libraries (asm extentions to the BASIC language) and execute interrupts from qb.  

7.1 has a few features over 4.5 as well.  You can use arrays in type definitions, and programs can be stored in EMS memory.  There also seems to be some new data types like CURRENCY.  It also has some cleaner code as well.

Microsoft also made a final version of QB, called Visual Basic for Dos.  It generates pretty much the cleanest, fastest code of any of the QBs, though it isnt used much for some reasons.
Logged

i]"I know what you're thinking. Did he fire six shots or only five? Well, to tell you the truth, in all this excitement, I've kinda lost track myself. But being as this is a .44 Magnum ... you've got to ask yourself one question: 'Do I feel lucky?' Well, do ya punk?"[/i] - Dirty Harry
TheBigBasicQ
*/-\*
*****
Posts: 4550



WWW
« Reply #17 on: October 21, 2003, 10:13:52 AM »

Quote from: "oracle"


Oracle you are such a bully Wink That doesnt leave him any choice. He has to download Qb 4.5. My link will allow him to choose between qb 4.5 and 7.1.

Andy, I recommend Qb7.1 =)
Logged
oracle
*/-\*
*****
Posts: 3652



WWW
« Reply #18 on: October 21, 2003, 04:33:08 PM »

Like I said, qb45=compatibility+most the features of 7.1. Sterling Christensen is always being caught out using QB7.1 commands and posting them here, where the vast majority of us can't use them.

Besides, he already has 7.1  Tongue
Logged

toonski84
__/--\__
*****
Posts: 2567



« Reply #19 on: October 21, 2003, 07:13:17 PM »

"can't use them?" - You can install more than one on your computer, silly.
Logged

i]"I know what you're thinking. Did he fire six shots or only five? Well, to tell you the truth, in all this excitement, I've kinda lost track myself. But being as this is a .44 Magnum ... you've got to ask yourself one question: 'Do I feel lucky?' Well, do ya punk?"[/i] - Dirty Harry
seph
Na_th_an
*****
Posts: 1915



« Reply #20 on: October 21, 2003, 08:39:31 PM »

ORRRRRRRRRRR you can do it MY way, which is so much better than theirs Wink

HERE!

Code:
SCREEN 13

paintScreen
'SLEEP

gamePause 1
SLEEP

paintScreen
'SLEEP

gamePause 2
SLEEP

SUB gamePause (method%)
        SELECT CASE method%
        CASE 1
                FOR y% = 0 TO 99
                        FOR x% = 0 TO 159
                                PSET (x% * 2, y% * 2), 0
                        NEXT x%
                NEXT y%
        CASE 2
                FOR y% = 0 TO 99
                        FOR x% = 0 TO 159
                                PSET (x% * 2, y% * 2), 0
                                PSET (x% * 2 + 1, y% * 2 + 1), 0
                        NEXT x%
                NEXT y%
        END SELECT
END SUB

SUB paintScreen
        CLS
        PAINT (0, 0), 5
END SUB
Logged

earn.
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!