Qbasicnews.com
November 12, 2019, 07:35:55 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Back to Qbasicnews.com | QB Online Help | FAQ | Chat | All Basic Code | QB Knowledge Base
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: WAVE in Future Library 3.5  (Read 1756 times)
Karelius
Member
*
Posts: 88



« on: May 24, 2007, 11:36:26 AM »

I have a problem, the wave file not play...

Code:
DECLARE SUB DmaState (StopGo%)
DECLARE FUNCTION WavDone% ()
DECLARE SUB SetStereo (BYVAL OnOff%)
DECLARE SUB SetSurround (BYVAL OnOff%)
DECLARE SUB LoadWAV (FileName$, SampleRate&)
DECLARE SUB StopAndReset ()
DECLARE SUB SpeakerState (OnOff%)
DECLARE SUB SBSetup (BasePort%, Ldma%, Hdma%, Irq%, SBtype%)
DECLARE FUNCTION Lwavedata% ()
DECLARE FUNCTION Rwavedata% ()
DECLARE FUNCTION GetMasterVolL% ()
DECLARE FUNCTION GetMasterVolR% ()
DECLARE SUB SetMasterVolL (BYVAL Vol%)
DECLARE SUB SetMasterVolR (BYVAL Vol%)
DECLARE FUNCTION GetWaveVolL% ()
DECLARE FUNCTION GetWaveVolR% ()
DECLARE SUB SetWaveVolL (BYVAL Vol%)
DECLARE SUB SetWaveVolR (BYVAL Vol%)
DECLARE SUB SetChannel (ChannelNum%, XMShandle%, WavFile$)
DECLARE SUB PlayChannel (BYVAL ChannelNum%)


I've write:

Code:

'$INCLUDE: 'future.bi'
CALL SBSetup(220, 1, 3, 5, 4)
CALL LoadWAV("c:\windows\media\tada.wav", 4)


The file Wave is a 8 bit 22050Hz Mono; in the code lacks something?  :Huh:
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!